[Velocity] Data processing delays
Incident Report for Code Climate
Resolved
The performance fix is performing as expected and the component for calculating language contributions metrics has caught up on its backlog. This incident is resolved.
Posted Dec 10, 2019 - 13:46 EST
Monitoring
We've deployed a performance fix for the language contributions calculation, and are monitoring the component.
Posted Dec 10, 2019 - 13:43 EST
Update
We've identified a performance issue calculating metrics related to language contributions. We've disabled updates to these metrics for the time being so that other metrics will be correct.

At this point all pull request updates are caught up and up to date. We are investigating the performance issue related to language contributions.
Posted Dec 10, 2019 - 11:31 EST
Identified
We're seeing backup in a component of our data processing pipeline which is delaying updates to pull request data. Pull requests and related data may be missing or stale while we attend to this issue. We've identified the cause and are taking remedial actions and investigating root causes.
Posted Dec 10, 2019 - 11:02 EST
This incident affected: Code Climate Velocity.