[Velocity] data processing delays
Incident Report for Code Climate
Resolved
We are caught up with our backlog. Our workaround for the responsible repository is still in place: we are resolving this incident, and will implementing a permanent fix soon.
Posted Mar 05, 2020 - 10:48 EST
Update
We identified a specific repository causing errors within a component that analyzes commit data. We have implemented a workaround to avoid processing data for that specific repository for the moment so that the system can catch up while we work to identify the root cause and implement a more permanent fix.
Posted Mar 05, 2020 - 09:08 EST
Investigating
We are seeing failures in our data processing pipeline preventing completion of new repository imports & Jira data syncing operations. We are investigating. Syncing of new data from repositories that are already fully imported does not appear impacted right now.
Posted Mar 05, 2020 - 08:07 EST
This incident affected: Code Climate Velocity.