[Velocity] Data gaps affecting some reports
Incident Report for Code Climate
Resolved
We are caught up with backfilling data and believe data is up to date for the majority of customers. A small number of customers using on-prem git hosting are not fully caught up yet, and we are communicating with those individual organizations separately.
Posted Nov 20, 2019 - 18:18 EST
Identified
We've identified a regression in a component of our data processing pipeline that led to us failing to ingest certain data for events. Specifically, certain events related to pull requests and comments on Jira issues. The consequence of this would be that some metrics related to pull request review cycles, cycle time, and others would be incorrect. Issue comments would fail to appear on the activity log.

The regression was introduced on November 4th, so data since then would be affected. We have identified and fixed the regression, so events occurring now are being correctly ingested. We are working to backfill data from the affected time period to fix historical data. We apologize for the error.
Posted Nov 19, 2019 - 18:07 EST
This incident affected: Code Climate Velocity.