Delayed Platform Analysis
Incident Report for Code Climate
Resolved
This incident has been resolved.
Posted Jan 18, 2017 - 04:34 EST
Monitoring
Analysis metrics have returned to normal levels.
Posted Jan 18, 2017 - 04:27 EST
Update
Graphs seem to be turning around now. Processing time for initial git fetch operations has dropped and the system is taking on more builds.
Posted Jan 18, 2017 - 04:22 EST
Identified
We're experiencing a higher than normal rate of git fetch timeouts from GitHub. Requests either take a long time to complete or fail completely. A quick search on Twitter shows similar reports but GitHub has yet to open an incident on their end.
Posted Jan 18, 2017 - 03:48 EST
Investigating
We're seeing a delay in platform analysis. We're looking into it.
Posted Jan 18, 2017 - 03:35 EST