Analysis Stopped
Incident Report for Code Climate
Resolved
Amazon is now reporting as fully available, we've regained access to manage our instances, and our system appears healthy.
Posted Jul 19, 2016 - 17:10 EDT
Update
AWS has confirmed their increased API error rates and also notified of reduced network connectivity which we believe is the root cause of our degraded service. We do have a set of nodes back online now and analyses are occurring. Unfortunately, demand is high and the AWS API outage is preventing our registering new nodes to keep up.
Posted Jul 19, 2016 - 14:56 EDT
Update
Amazon Web Services is currently reporting increased API error rates in our region. We suspect this is the cause or our inability to register analysis nodes into service. It's also making it incredibly difficult to troubleshoot. We'll provide updates as we have them.
Posted Jul 19, 2016 - 14:33 EDT
Identified
We've been alerted that no analyses are taking place and our analysis worker instances are in a failed state. We're investigating that that's true and working to correct the cause.
Posted Jul 19, 2016 - 14:22 EDT