Delayed Churn Calculations
Incident Report for Code Climate
Resolved
We consider this incident resolved. We're going to increase our normal worker count to prevent a recurrence and better handle these kind of increases in churn-calculation workload.
Posted Jun 28, 2016 - 12:56 EDT
Monitoring
The new workers have brought calculation time back to normal levels. We'll continue investigating the root cause.
Posted Jun 28, 2016 - 11:59 EDT
Identified
We've been alerted to slow churn calculations (the metric for the frequency of changes to a particular source code file). Users may find these metrics don't show up or aren't up to date for up to 8 minutes. We're bringing on more workers to bring that time down, while investigating the source of the problem.
Posted Jun 28, 2016 - 11:48 EDT